Cannot export shnapps snapshot

solved

#1

after using command

schnapps export 15 /srv

i am getting error:

tar: unrecognized option: one-file-system
BusyBox v1.29.3 () multi-call binary.

it seems the the tar within busybox doesn’t support option like --one-file-system


#2

Check whether the tar package installed and install it if necessary and see if that sorts the matter.
schnapps export worked for me on TOS 3.11.1

busybox implementations are lightweight and known to have some caveats.


#3

do you have an upgraded system?
i installed my system cleanly from medkid 3.11 through reset option 4.

after

opkg install tar

i could perform schnapps export. seems to me there are some things missing in medkit of version 3.11.
don’t know about the current version of medkit


#4

considering schnapps being one of the base features of TOS and apparently dependent on tar the package is however curiously absent from the TOS’s base package.

I have got in my user.lua list.

Glad it is working now for you.

N.B. There is a solved :white_check_mark: to the thread, if you feel that the issue has been resolved


Support for Quectel EP06 LTE-A?