Cannot connect to my Turris. How do I reset to defaults?!?


#1

Sorry for this DFU newbie question.

I just got my Turris and got things up and running while connected via ethernet to my Windows 10 laptop and also ethernet to my modem. So that I can test things, I changed the ip address to 192.168.5.1

After a while, I unplugged the Turris and moved it to my router shelf… When I reconnect the power and ethernet, it did not work.

I’ve now reconnected it to my laptop and still cannot connect to it…

On the front of the Turris, the power, Lan’x’, Wan and PCI2 LED’s are lit. The LAN & WAN LEDs flash occasionally.
On my laptop, the window network diagnostics say that Ethernet does not have a valid IP configuration.

I’ve rebooted the router and my laptop with no luck. I’ve tried depressing the reset button on the back of the router for various lengths of time… still no luck.

Am I missing something really obvious?

TIA

Al


#2

every so often all of the lights on the front of the router flash and then revert to the above.

BTW, it is not a cable issue… if I unplug the LAN & WAN cables from the turris and connect them to another router, things work properly.


#3

To do factory reset you have to press reset button untill three leds are lit and then release it. Router will go trough loop of greens and red leds and after a while it will boot back to factory version (you will have to set it up again).

On your original problem. Did you checked that you don’t have some additional network settings in Windows? Have you tried it with some other device?


#4

Thanks for your response! I’m back online again. TBH I’m not sure what got things going again because I thought I’d reset properly previously but apparently not.

there seem to be a few glitches in the process - after holding the reset button until 3 LEDs change to red, all LEDs started flashing and did not stop. But once I rebooted the router, I could connect to things at 192.168.1.1 and get the setup wizard.
There was another hiccup in the setup wizard, the screen stuck all day on the second or third page of the wizard. After forcing a refresh in the browser, the admn UI loaded as one would expect.

Al


#5

I don’t know how you manage to do all three leds red without lighting up fourth led but ok. You managed to get to factory so it does’t matter now.

The glitch in wizzard on second or thirt page could be because of internet connection because that should be network connection test but you description seems to me be more relevamt to known glitch at update step where we have to reboot router to apply updates on switch config and in that time wizzard glitches as it looses connection to router for sime time.


#6

I’ll try resetting again…
Just did it now and waited until the 4th LED changed to red… they flashed for a bit and now all are red and have been for a couple of minutes…

Is there an FAQ page that explains the meaning of the LEDs during reset (the proper function LED are obvious)


#7

Ou I think that you missunderstood me. I was telling you number of lit leds not red leds. If you have three red leds then you have four leds lit. And factory reset is with three leds lit. Four leds lit is medkit reflash from usb drive (to update/recover factory image).

All this is described in official documentation: https://www.turris.cz/doc/en/start
What you are looking for is here: https://www.turris.cz/doc/en/howto/omnia_factory_reset


#8

Ooops… like I said, I’m a Turris Noob.

Thanks for the links. With three leds lit, things reset and I got the config wizard again. but I don’t seem to get through the wizard properly…

I got stuck at step three a couple of times (so I reset and started again). Finally step 3 worked but I got an error in step 6:


I never successfully got past step 8… I changed the router IP to 192.168.5.1 and the connection kept getting reset… I’d close the window and start again (at step 8 after logging in and the page would reset). If I changed back to prior steps, I’d get to step 8 again then the connection would reset. I jumped to step 9 and finished with the following message:

Does this help at all?


#9

That step six error is what I was talking about in previous post. We know about it and we can’t do anything about it at the moment.

If you change ip address at step 8 then you have to reload your pc network. Router restarts its network (will result to temporally unaccesibility for few minutes max). But your pc won’t try to reload new ip uddress. Easiest way is to just disconnect and reconnect ethernet cable. That is also why page reload is needed on step 8 when you change ip address. Just press next again after network reload.

And at last that error from updater is probably because we are starting updater in some cases after start of the system and at that time you had no internet connection. That just tells you that fetch for updates was unsuccessful because of no internet connection. If you have internet connection and that message is some what old then there is nothing to be worried about.