Cannot connect to ISP's PPPoE

OK, I’m going to start a new thread because after more than two weeks of posting on other threads, I’m still not able to get the Turris to connect to my ISP’s PPPoE service.

Any other suggestions very much appreciated. Here’s what I’ve done to date:

  • Re-flashed the firmware with the latest version downloaded from the Turris site (Four times now)

  • Tried to connect using PPPoE option

  • Tried connecting using Static IP

  • Tried Connecting using DHCP

  • Cloned the mac address from the existing working router (Apple Airport Extreme) to the Turris

  • Asked for advice from my ISP (no additional suggestions)

  • Owner of ISP came to my premise and tried to connect the router while monitoring the authentication process in real time. Router is correcting sending authentical crendential to the Turris; the authentication server at the ISP is receiving the correct authentication credentials and returning a request to connect to the Turris but the Turris is not connecting after receiving the handshaking response from the ISP’s servers.

  • Asked for help from Turris customer support site. Response after three days was that I should reflash the firmware with the latest version, which I did again, and again. It still doesn’t work.

  • Asked customer support to liaise with my ISP to determine why the Turris isn’t connecting after the ISP server is sending authentication handshake. (Friday 6 Jan) No response.

Any thoughts from anyone on how to identify what the problem may be? I’ve spent upwards of 8 hours on this now and nearly ready to package it up and send it back.

Any help or suggestions greatly appreciated.

BTW, is there a way to post the error log on the thread other than cut and paste?

Try ask help from CZ.NIC by mailing tech.support@turris.cz

Thanks @white. Shall do. Still no response from turris tech support after four days.

BTW Firmware version 3.5 is expected this week so when it is released check if it helps.

has this fix: “• There were problems with PPPoE athentication via CHAPS, it is fixed now, PPPoE should work smoothly.”

After the most recent firmware update which patched the flaw in CHAP PPPoE authentication code, I entered the login credentials and everything instantly worked perfectly without issue. Shame that it took so long for this fundamental flaw to be addressed – I wasted countless hours trying every possible option, thinking it must have been something I was doing wrong and all along it was a flaw in the firmware that wouldn’t permit the modem to authenticate.

I only got around to installing it last night but thus far all’s good. No dramas at all with the nbn FttP NTD. Lightning fast --getting the full 100/40! The ac wifi on the Turris leaves my previous Apple WiFi access points for dead, and the wifi from the Turris router now covers a larger footprint around the house than three Apple access points did previously. Somehow even penetrating 400mm thick stone walls! And at least 3X the speed of the g/n routers.

Thrilled that it’s finally connecting to the WAN!