Can not use Reforis on TOS 5+ - ControllerMissing

Hi. I am unable to start Reforis on TOS 5+ on my Omnia.
I always get an ControllerMissing error:

ControllerMissing: Connection to controller 0000D858D7007753 is lost.
  args = ('Connection to controller 0000D858D7007753 is lost.',)
  device_id = '0000D858D7007753'
  with_traceback = <built-in method with_traceback of ControllerMissing object> 

Please tell me what information I have to provide and what actions I can take to try to get Reforis working.
I am worried it gets replaced and I end up with no running management console on my device.

You will need to reach our technical support department so we would be able to look at it more. Would you please take a look at our Getting help article?

I am having the same issue after an upgrade from Turris 3. I sent the error info to support and waiting to hear back.

Same here. After updating Turris Omnia 3.X to 5.X, reforis doesn’t work…

Update: I’ve tried to reinstall it just in case but still not working.

Problem solved. I followed the thread “Optional migration from Turris OS 3.x for advanced users” since I also got errors in the advanced administration, ‘Software’ when trying to list packages. Changing to the alternate update repository worked and I was able to list available packages. Suspecting the problem to be related to missing components in Reforis, I searched for that keyword and saw that some of the plugins listed were not installed. I installed them and now it works.

The team at Turris did a great job with the new interface.

Do you mind to list the packages/plugins you installed to fix the issue? All of them?

Edit: In any case, I’ve installed all reforis plugins and it works :slight_smile:


1 Like


Installing the missing rforis-plugins also fixed it for me.

Thanks a heap!

This module fixed my issue: reforis-netboot-plugin

When will be this fixed in tos3to4?

1 Like

Right now, the fix is in the HBK branch. It will be part of Turris OS 5.1.4.

1 Like

I have similar issue on HBS branch:
Turris OS version 5.1.3
Turris OS branch hbs
Kernel version 4.14.202

You can see the answer above.

I am on TurrisOS 5.1.4 and I have a similar Issue.
Is the solution still the same as stated above?

Were you using opt-in migration?

Is that the one that was in the package manager? I used that one :smiley:
And I already cleaned /etc/updater/conf.d/opkg-auto.lua


  1. Cleaned /etc/updater/conf.d/opkg-auto.lua off unecessary entries
  2. opkg-cl update
  3. opkg install reforis reforis-diagnostics-plugin reforis-netboot-plugin reforis-netmetr-plugin reforis-remote-devices-plugin reforis-snapshots-plugin
  4. Profit

It seems it is still not fixed.
I was migrated today from TOS 3 to 5.2.7 and reforis did not worked for me too.
I fixed it by

opkg-cl update
opkg install reforis-netboot-plugin

Same here, updated just now. Your solution also worked for me.

I got same issue, resolved it. But why do I need reforis netboot?
I noticed that it is consuming most of the resources now. That does not seem to be clever.

Yep, My dear @viktor - it still has not been fixed.