Came home from work, no longer have DNS

Sorry if I put this in the wrong section, but anyways, my internet was working this morning before I went to the gym around 7am eastern time (New York timezone.) I came home from work around 8pm, and now I have no internet connection on my laptop, unless I start TorGuard VPN. Without it, I get a “connected” status, but with no internet. My android is showing “connected, no internet” as well. I haven’t changed any modifications at all since I first got this thing running, and I don’t know enough about network stuff to try and tweak those settings in the first place.

Attached is the diagnostic logs.

############## dns
resolver.common=resolver
resolver.common.interface=‘0.0.0.0’ '::0’
resolver.common.port=‘53’
resolver.common.keyfile=’/etc/root.keys’
resolver.common.verbose='0’
resolver.common.msg_buffer_size='4096’
resolver.common.msg_cache_size='20M’
resolver.common.net_ipv6='1’
resolver.common.net_ipv4='1’
resolver.common.forward_upstream='1’
resolver.common.prefered_resolver='kresd’
resolver.common.prefetch='yes’
resolver.common.ignore_root_key=‘0’
resolver.kresd=resolver
resolver.kresd.rundir=’/tmp/kresd’
resolver.kresd.log_stderr='1’
resolver.kresd.log_stdout='1’
resolver.kresd.forks='1’
resolver.unbound=resolver
resolver.unbound.outgoing_range='60’
resolver.unbound.outgoing_num_tcp='1’
resolver.unbound.incoming_num_tcp='1’
resolver.unbound.msg_cache_slabs='1’
resolver.unbound.num_queries_per_thread='30’
resolver.unbound.rrset_cache_size='100K’
resolver.unbound.rrset_cache_slabs='1’
resolver.unbound.infra_cache_slabs='1’
resolver.unbound.infra_cache_numhosts=‘200’
resolver.unbound.access_control=‘0.0.0.0/0 allow’ ‘::0/0 allow’
resolver.unbound.pidfile=’/var/run/unbound.pid’
resolver.unbound.root_hints=’/etc/unbound/named.cache’
resolver.unbound.target_fetch_policy='2 1 0 0 0’
resolver.unbound.harden_short_bufsize='yes’
resolver.unbound.harden_large_queries='yes’
resolver.unbound.key_cache_size='100k’
resolver.unbound.key_cache_slabs='1’
resolver.unbound.neg_cache_size='10k’
resolver.unbound.prefetch_key='yes’
resolver.unbound_remote_control=resolver
resolver.unbound_remote_control.control_enable='no’
resolver.unbound_remote_control.control_interface=‘0.0.0.0’ ‘::0’

-rw-r–r-- 1 root root 562 Jan 12 20:51 /etc/root.keys
68774c179b512d71cf54a08f31231ee9 /etc/root.keys
ls: /etc/unbound/root.key: No such file or directory
md5sum: can’t open ‘/etc/unbound/root.key’: No such file or directory

/etc/resolv.conf:search lan
/etc/resolv.conf:nameserver 127.0.0.1
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘api.turris.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘www.rhybar.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘*.wilda.rhybar.0skar.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘*.wilda.nsec.0skar.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘*.wild.nsec.0skar.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘*.wilda.0skar.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘*.wild.0skar.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘www.wilda.nsec.0skar.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘www.wilda.0skar.cz’: Try again
Server: 127.0.0.1
Address 1: 127.0.0.1 localhost

nslookup: can’t resolve ‘*.wilda.rhybar.ecdsa.0skar.cz’: Try again
************** dns
############## network
network.loopback=interface
network.loopback.ifname='lo’
network.loopback.proto='static’
network.loopback.ipaddr='127.0.0.1’
network.loopback.netmask='255.0.0.0’
network.globals=globals
network.globals.ula_prefix='fdfa:944e:f4a2::/48’
network.lan=interface
network.lan.ifname='eth0 eth2’
network.lan.force_link='1’
network.lan.type='bridge’
network.lan.proto='static’
network.lan.ipaddr='192.168.1.1’
network.lan.netmask='255.255.255.0’
network.lan.ip6assign='60’
network.wan=interface
network.wan.ifname='eth1’
network.wan.proto=‘dhcp’
network.wan6=interface
network.wan6.ifname=’@wan
network.wan6.proto='dhcpv6’
network.@switch[0]=switch
network.@switch[0].name='switch0’
network.@switch[0].reset='1’
network.@switch[0].enable_vlan='1’
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0’
network.@switch_vlan[0].vlan='1’
network.@switch_vlan[0].ports='0 1 2 3 5’
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0’
network.@switch_vlan[1].vlan='2’
network.@switch_vlan[1].ports=‘4 6’

ipv4:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 532
inet 68.98.160.61/21 brd 68.98.167.255 scope global eth1
valid_lft forever preferred_lft forever
14: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
valid_lft forever preferred_lft forever
default via 68.98.160.1 dev eth1 proto static src 68.98.160.61
68.98.160.0/21 dev eth1 proto kernel scope link src 68.98.160.61
68.98.160.1 dev eth1 proto static scope link src 68.98.160.61
192.168.1.0/24 dev br-lan proto kernel scope link src 192.168.1.1

ipv6:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 532
inet6 2600:8806:7f00::910:20b0:5deb:373e/128 scope global noprefixroute dynamic
valid_lft 83527sec preferred_lft 83527sec
inet6 fe80::da58:d7ff:fe00:352f/64 scope link
valid_lft forever preferred_lft forever
14: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 2600:8806:4000:6f::1/64 scope global noprefixroute dynamic
valid_lft 83527sec preferred_lft 83527sec
inet6 fdfa:944e:f4a2::1/60 scope global noprefixroute
valid_lft forever preferred_lft forever
inet6 fe80::da58:d7ff:fe00:352e/64 scope link
valid_lft forever preferred_lft forever
15: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fe80::6f0:21ff:fe23:2e55/64 scope link
valid_lft forever preferred_lft forever
16: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fe80::6f0:21ff:fe24:3f1/64 scope link
valid_lft forever preferred_lft forever
default from 2600:8806:4000:6f::/64 via fe80::6273:5cff:fe72:a5d9 dev eth1 proto static metric 512
default from 2600:8806:7f00::910:20b0:5deb:373e via fe80::6273:5cff:fe72:a5d9 dev eth1 proto static metric 512
2600:8806:4000:6f::/64 dev br-lan proto static metric 1024
unreachable 2600:8806:4000:6f::/64 dev lo proto static metric 2147483647 error -113
fdfa:944e:f4a2::/64 dev br-lan proto static metric 1024
unreachable fdfa:944e:f4a2::/48 dev lo proto static metric 2147483647 error -113
fe80::/64 dev br-lan proto kernel metric 256
fe80::/64 dev wlan0 proto kernel metric 256
fe80::/64 dev eth1 proto kernel metric 256
fe80::/64 dev wlan1 proto kernel metric 256
************** network

Also, is it supposed to take forever to get a full diagnostic? I ended up just doing the network and DNS diagnostics because trying to do a full diagnostic seems to take a long time. Twenty minutes or so has passed and it still says “preparing.”

I can get around this temporarily by using my VPN client, but I really shouldn’t have to do that. Any idea what happened?

I tried enabling DDNS because there was a red mark next to it saying that it was disabled, click here to enable. That did nothing, and so I told the router to restart. Now instead of the default login page, it asks for a username and password. I don’t remember having to put in a username, but root, admin and administrator all don’t work.

So now I have no DNS, and I can’t even access the router itself.

Plugging in my ethernet cable got me back to the login screen, so disregard that last part. Looks like the wired internet is fine, but the wireless is majorly messed up. I checked this by turning on my XBOX one which is plugged in with an ethernet, and that works fine.

Check the content of the file “/tmp/resolv.conf.auto”. There should be lines with the text “nameserver”.

And if you are running Turris 3.5 and there are more than four nameserver lines you have probably hit a known bug where kresd stop working due too many nameservers.

1 Like

Thank you white. Here is the results of that search, which servers should I delete?

root@turris:~# cat /tmp/resolv.conf.auto | grep nameserver
nameserver 68.105.28.11
nameserver 68.105.29.11
nameserver 68.105.28.12
nameserver 2001:578:3f::30
nameserver 2001:578:3f:1::30
nameserver 2001:578:3f::30
nameserver 2001:578:3f:1::30
nameserver 2001:578:3f::30
nameserver 2001:578:3f:1::30

You could try the following.

Take a backup from the original startup script:
cp -i /etc/init.d/kresd /root/kresd.backup

Then edit file /etc/init.d/kresd with text editor like vi or nano. Find a line " SERVERS=$(sed -ne ‘s/^nameserver (.*)/\1/p’ /tmp/resolv.conf.auto | sort)" and change it like this:

SERVERS=$(sed -ne ‘s/^nameserver (.*)/\1/p’ /tmp/resolv.conf.auto | sort -u | head -n4)

And finally restart kresd with command
/etc/init.d/kresd restart

Looks like that did it! Thank you!