Boot Recsue is broken


#1

After flashing wrong uboot and recovering uboot with kwboot all Boot Rescue funktions are not working.
How can i recover Boot Rescue ?

Thanks in advance
Michael

U-Boot 2015.10-rc2 (Dec 18 2018 - 13:34:08 +0100), Build: jenkins-omnia-stable-363

SoC: MV88F6820-A0
Watchdog enabled
I2C: ready
SPI: ready
DRAM: 2 GiB (ECC not enabled)
Enabling Armada 385 watchdog.
Disabling MCU startup watchdog.
Regdomain set to **
MMC: mv_sdh: 0
SF: Detected S25FL164K with page size 256 Bytes, erase size 64 KiB, total 8 MiB
PCI:
00:01.0 - 168c:002e - Network controller
PCI:
01:00.0 - 11ab:6820 - Memory controller
01:01.0 - 168c:003c - Network controller
Model: Marvell Armada 385 GP
Board: Turris Omnia SN: 0000000*********
Regdomain set to **
SCSI: MVEBU SATA INIT
SATA link 0 timeout.
SATA link 1 timeout.
AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl SATA mode
flags: 64bit ncq led only pmp fbss pio slum part sxs
Net: neta2
Hit any key to stop autoboot: 0
Setting bus to 1
BOOT RESCUE
SF: Detected S25FL164K with page size 256 Bytes, erase size 64 KiB, total 8 MiB
device 0 offset 0x100000, size 0x700000
SF: 7340032 bytes @ 0x100000 Read: OK
Bad Linux ARM zImage magic!
=>


#2

This (and the other thread) seems all a bit messed up. It is hard to grasp what state the router is actual in.

However, have your tried yet to reset the uboot env?


#3

Thanks for reply.

I have tried to reset uboot environment with " env default -a" and “saveenv” but no change.
If i try Reset procedure 2,3,4 or 5 i get message “Bad Linux ARM zImage magic!”
Booting Debian (https://wiki.debian.org/InstallingDebianOn/TurrisOmnia) or OpenWRT
(https://www.lteforum.at/mobilfunk/turris-omnia-lte-router-project.6379/seite-37.html#post-175315)
via TFTP is possible. If i flash OpenWRT with TFTP and SYSUPGRADE OpenWRT boot but it is not
possible to log in.


#4

I am not sure that you got the TO boot env and not something else from the work you conducted previously (wrong u-boot file and kwboot).

There are 1 or 2 boot env samples in the forum, to compare with.

Maybe a silly idea but try a different pen drive and/or different drive format.


#5

I used uboot from here : https://api.turris.cz/openwrt-repo/omnia/nor_fw/
kwboot from here does not work, i used kwboot from debian sid.
Boot Rescue Nr. 5 (shell) needs no pen drive and does not work to.
Uboot environment is identical with the version i found here in forum.

Here (https://openwrt.org/toh/turris_cz.nic/turris_cz.nic_omnia) i found
that memory layout has 2 partitions. I think recovery partition is damaged.
How can i write this partition ?


#6

Did you have a look at https://openwrt.org/docs/techref/flash.layout ?

This one https://www.cs.cmu.edu/~ecc/old-dockstar-howto.html mentions

Use the mtd-utils commands to flash the /dev/mtd2 partition:


#7

It could also be the case, depending on age/usage, that the NAND is worn out. Reckon in such case you would need to contact the TO support (or worst case procure a new unit, unless you are familiar with board soldering and replacing the NAND).


#8

Rescue image is located in NOR, so content of the eMMC has no efect. Once you boot your Omnia (you can use omnia-initramfs-zimage from the link bellow), erase partitions mtd0 and mtd1 and write into them files from https://repo.turris.cz/omnia/nor_fw/

uboot-turris-omnia-spl.kwb to /dev/mtd0
omnia-initramfs-zimage to /dev/mtd1


#9

After flashing omnia-initramfs-zimage to /dev/mtd1 it is possible to start Boot Rescue.
With this Boot Rescue it is not possible to flash a Image with 4 LED reset.
In serial console i can see 10 times “/bin/rescue.sh: line 1: /usr/bin/awk: not found”
“which awk” says “/bin/awk”. Where can i find a correct version ?


#10

With this version boot rescue works correct : https://repo.turris.cz/omnia-kernel-modules/nor_fw/omnia-initramfs-zimage
Many thanks for help to all.