Boot loop after latest patch/reboot?

After tonights reboot/pending patches my router just boot loops. No client connections are possible. (Wifi down and LAN interfaces do not give any link).

Also tried restore a snapshot with holding the button and waiting for two leds. When flashing latest medkit it still bootloops.

Is anyone else running the 2016 Indiegogo - 2GB board? I just wonder if there was any low-level/bootloader regression in the last update or if the hardware just have up.

1 Like

The OpenWrt medkit recovery works
https://downloads.openwrt.org/releases/21.02.3/targets/mvebu/cortexa9/omnia-medkit-openwrt-21.02.3-mvebu-cortexa9-cznic_turris-omnia-initramfs.tar.gz

But the Turris loops gets into a bootloop, without LAN connectivity.
https://repo.turris.cz/hbs/medkit/omnia-medkit-latest.tar.gz

Any suggestions? I sadly do not have any Serial dongle to debug further.

Similar problems did not occur in the forum, I run Turris Omnia 1Gb Invoice date: November 9, 2016. The system is installed on internal memory or mSTATA SSD?

0 - the first solution is to return to the previous version of the system Omnia - Turris Documentation
1- As a more complex solution without a detailed analysis of the problem, I recommend purchasing a serial dongle and installing the system on an mSATA disk
3 - the easiest is to try to agree with the support of CZ.NIC and send the machine to them (I also successfully completed it in an emergency)
4 - youre router is Omnia or MOX ?

=====
It would help if possible to find out some details, logs and the like

1 Like

The same thing happened today with my Omnia.
Restored it to factory defaults (3 led) and then everted to old snapshot using schnapps

1 Like

TO 2016 2GB 5.3.10 HBT - no booting problems at all, everytime.

Great :smiley: happy to hear!

still waiting for a UART cable to be delivered, lets see where it leads.

Allright, so, I got the UART running. In normal boot mode it loops with this information:

U-Boot SPL 2015.10-rc2 (Aug 18 2016 - 20:43:35)
High speed PHY - Version: 2.0
SERDES0 card detect: SATA

Initialize Turris board topology
Detected Device ID 6820
board SerDes lanes topology details:
 | Lane #  | Speed |  Type       |
 --------------------------------
 |   0    |  6   |  SATA0       |
 |   1    |  5   |  USB3 HOST0  |
 |   2    |  5   |  PCIe1       |
 |   3    |  5   |  USB3 HOST1  |
 |   4    |  5   |  PCIe2       |
 |   5    |  0   |  SGMII2      |
 --------------------------------
poll_op_execute: TIMEOUT
:** Link is Gen1, check the EP capability
PCIe, Idx 1: remains Gen1
:** Link is Gen1, check the EP capability
PCIe, Idx 2: remains Gen1
High speed PHY - Ended Successfully
DDR3 Training Sequence - Ver TIP-1.29.0
Memory config in EEPROM: 0x02
DDR3 Training Sequence - Switching XBAR Window to FastPath Window
DDR3 Training Sequence - Ended Successfully


U-Boot 2015.10-rc2 (Aug 18 2016 - 20:43:35 +0200), Build: jenkins-omnia-master-23

SoC:   MV88F6820-A0
       Watchdog enabled
I2C:   ready
SPI:   ready
DRAM:  2 GiB (ECC not enabled)
Enabling Armada 385 watchdog.
Disabling MCU startup watchdog.
Regdomain set to **
MMC:   mv_sdh: 0
SF: Detected S25FL164K with page size 256 Bytes, erase size 64 KiB, total 8 MiB
PCI:
  00:01.0     - 168c:003c - Network controller
PCI:
  01:00.0     - 11ab:6820 - Memory controller
  01:01.0     - 168c:002e - Network controller
Model: Marvell Armada 385 GP
Board: Turris Omnia SN: 0000000B0000{Hiding four digits}
Regdomain set to **
SCSI:  MVEBU SATA INIT
Target spinup took 0 ms.
SATA link 1 timeout.
AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl SATA mode
flags: 64bit ncq led only pmp fbss pio slum part sxs 
Net:   neta2
Hit any key to stop autoboot:  0 
Setting bus to 1
BOOT eMMC FS
BtrFS init: Max node or leaf size 4096
3379088 bytes read in 384 ms (8.4 MiB/s)
BtrFS init: Max node or leaf size 4096
18834 bytes read in 260 ms (70.3 KiB/s)
Kernel image @ 0x1000000 [ 0x000000 - 0x338f90 ]
## Flattened Device Tree blob at 02000000
   Booting using the fdt blob at 0x2000000
   Loading Device Tree to 0fff8000, end 0ffff991 ... OK

Starting kernel ...

I can also stop autoboot and get a prompt, (not familiar with this, u-boot?)

Can I get the kernel output somehow to the serial? or where should I start :slight_smile:

Ok, maybe tis gives some clues, but I have no idea, how to recover?

=> run distro_bootcmd
switch to partitions #0, OK
mmc0(part 0) is current device
Failed to mount ext2 filesystem...
BtrFS init: Max node or leaf size 4096
Scanning mmc 0:1...
Failed to mount ext2 filesystem...
BtrFS init: Max node or leaf size 4096

=> mmc info
Device: mv_sdh
Manufacturer ID: 90
OEM: 14a
Name: H8G4a 
Tran Speed: 52000000
Rd Block Len: 512
MMC version 4.0
High Capacity: Yes
Capacity: 7.3 GiB
Bus Width: 8-bit
Erase Group Size: 512 KiB
=> mmc part

Partition Map for MMC device 0  --   Partition Type: DOS

Part    Start Sector    Num Sectors     UUID            Type
  1     2048            15267840        cb480c72-01     83

It’s alive

env default -a
saveenv
from the serial.

And the 4-LED latest medkit. Also used a bluescreen computer to FAT32 format the USB-drive. Not sure what I did differently but finally some progress. Thanks all

1 Like

This post was flagged by the community and is temporarily hidden.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.