Automount Swap/Filesystem

I added a little 8GB USB drive just to write some logs onto.
I manually created a mount point and mounted it as a file system and directed some logs to it and it worked perfect.
Filesystem Mount Point
/dev/sda1 /mnt/8GB_USB

After a later reboot I noticed I had the sda1 mounted as two mount points. Which I guess is due to the Automount of swap and filesystems.

I cant imagine I would like to use this slow usb stick as swop so my question is:

Can I uncheck these automount or should should I do something else to avoid the usb stick to be used as swap and mounted twice?

From information I have from you now, I can only guess whats wrong. Try to look here: Samba USB Disk not showing in Windows 10

Thanks Weafyr

Exactly that way:
/dev/sda1 /tmp/run/mountd/sda1

So if I disable the automount for Swap and Filesystem, will something else be affected which might cause any problems or does it only mean I will have to create mount points myself?