Automatic Spindown of WD HDD

:+1: :relaxed: I understand what you mean now, just wanted to know your thoughts. Thanks for sharing.

I also had to use hdparm instead of hd-idle which didn’t work for me. Just beware of WD Green hard drives where option -S is behave differently, more info is here

1 Like

@axeli Thanks. Good to know. I am still not satisfied with how most of my drives behave. at least three don’t spin down poperly. The one blue WD drive, a 500GB HDD, doesn’t support APM or manipulation of the spindowntimer which is set to off.This drive let’s me send a spin down manually but not set or modify the timer.

That’s weird, if you can set it manually and it works, it also should work with timer. Can you try this?

Link to picture

hdparm -S 3 /dev/sda1

where “-S 3” normally 15 seconds is 10 minutes in this case and “/dev/sda1” replace with yours hard drive. Reboot & wait 10 minutes.

My 2TB WD Green doesn’t support APM_level either and this setup works.

1 Like

@axeli Alright. Will do try your suggestion. How do you solve the changing filesystem names after unplug/replug or reboot? I would want to change the startup command each time the filesystem name changes. EDIT Actually, further up you may see what error message I get when trying to issue the hdparm -S command.

Do you get same error with -S 3 ? Filesystem names didn’t change after reboot or unplug/re-plug in my case, so I didn’t have to do anything :confused:

1 Like

Yes, that particular WD Blue drive won’t allow any configuration, not even proper setting of the APM level. The only thing it listens to is the manual -y command.