Authentication Issue with Netatalk

My goal is to use my router as a Time Capsule for backups of my Mac like described in the OpenWRT wiki. I followed the instructions and managed to get the ZeroConf announcement to work meaning I can see the Time Capsule drive in my Finder/in the Time Machine menu. The issue is that I cannot connect to the drive: When I want to connect it asks me for my credentials as intended just to refuse them a moment later. What I verified:

  • the external drive is mounted and writable
  • my credentials seem to be correct (at least for a simple network share access)
  • the user owns the drive in question respectively has access to it

Looking at the logs of afp I see that everything is set up as it should:

2018-04-01T12:55:06+02:00 notice afpd[30262]: AFP/TCP started, advertising 10.111.222.1:548 (2.2.4)
2018-04-01T12:55:06+02:00 warning afpd[30262]: volume "Temp" does not support Extended Attributes, using ea:ad instead
2018-04-01T12:56:28+02:00 notice afpd[30561]: AFP statistics: 0.51 KB read, 0.38 KB written

whereby the last line seems to come from my failed connection attempt.

Same for avahi:

2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Found user 'nobody' (UID 65534) and group 'nogroup' (GID 65534).
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Successfully dropped root privileges.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: avahi-daemon 0.6.31 starting up.
2018-04-01T12:55:28+02:00 warning avahi-daemon[30329]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Loading service file /etc/avahi/services/afpd.service.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Joining mDNS multicast group on interface br-lan.IPv6 with address fd4a:cb4c:89cb::1.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: New relevant interface br-lan.IPv6 for mDNS.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Joining mDNS multicast group on interface br-lan.IPv4 with address 192.168.1.100.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: New relevant interface br-lan.IPv4 for mDNS.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Network interface enumeration completed.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Registering new address record for fd4a:cb4c:89cb::1 on br-lan.*.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Registering new address record for 192.168.1.100 on br-lan.IPv4.
2018-04-01T12:55:28+02:00 info avahi-daemon[30329]: Registering HINFO record with values 'ARMV7L'/'LINUX'.
2018-04-01T12:55:29+02:00 info avahi-daemon[30329]: Server startup complete. Host name is turris.local. Local service cookie is 341070528.
2018-04-01T12:55:30+02:00 info avahi-daemon[30329]: Service "Time Capsule" (/etc/avahi/services/afpd.service) successfully established.
2018-04-01T12:56:01+02:00 warning avahi-daemon[30329]: Invalid response packet from host 192.168.1.142.
2018-04-01T14:56:06+02:00 warning avahi-daemon[3434]: Last message 'Invalid response pac' repeated 1 times, suppressed by syslog-ng on turris

whereby the last two lines seem to come from my failed connection attempt.

To me this looks like my Mac has an issue in sending a correct connection request. Does anyone else have some insights here? Thanks!