Android Issue post 3.8


#21

Same experience, anyone has a workaround or fix?
Getting frustrating…

I tried to delay the key exchange and change the encryption, no change…


#22

As suggested in Solution found for WiFi clients disconnects getting rid of TKIP encryption worked for me. My Nexus 5X has an uptime above 200 hours, and Wi-Fi is behaving fine.

This is a workaround, and it broke the connectivity of one of my oldest devices, but way better than getting frustrated with my smartphone :slight_smile:


#23

Sure enough, the issue was back the very day after I dropped the above message. Back to square one, with a very erratic Wi-Fi


#24

Just dropping in and want to comment that it should has something to do with Wifi. I have a similar setup like the others here (that is: knot for externa resolving, dnsmasq for internal resolving, DNS forwarding enabeld, DNSSEC enabled, Android 8.1, and the stable branch on my Turris Omnia), but with the difference: I am offloading my Wifi to an access point by ubiquiti. There were never any problems with this setup as long as i had the Omnia and the Ubiquiti AP in use.


#25

In fact I have 3 Wi-Fi , 2.4 and 5 GHz on the Omnia, and another 2.4 on an OpenWRT generic AP with the same SSID/password. The second AP is fully transparent, Wi-Fi and upstream Ethernet to the Omnia are bridged, no firewall, no subnet or NAT. The issue with my Android 8.x occurs on both devices.


#26

What chipset do you have in your AP?

It may be related to the Atheros chipsets.
There are some tickets in OperWRT that may be related.


#27

It’s an Atheros based. Next time my Android device will consistently drop the Wi-Fi, I will turn it off, to be absolutely sure that it is not interfering.


#28

I am still affected by the issue. The only workaround solution is to reboot the smartphone. Sometimes the issue arises after as few as 6 hours, and when lucky after a few days

It looks like Nexus 5X and apparently 6P are behaving poorly with with a wide range of routers. Omnia and OpenWRT are likely be off the hook.

There is a bug report on Google tracker that is open for a long while. There may be several underlying issues. Some say that black magic help, other are considering dropping those (ageing) units, as Google is not responsive at all.


#29

Both are supported by LineageOS. Has anyone tried loading an alternative firmware like that on the phones?


#30

After returning my Nexus5X 2 times in RMA, I did not find the motivation to migrate it to LineageOS, but I guess I’ll be doing it in the coming months as Google stopped providing security updates after the November one.

In my case, it seems that keeping the Bluetooth on is the black magic I was looking for.


#31

I noticed that before disconnecting, the phone had issues with some sites.
After some testing I saw that the phone had an ipv6, from the router, but not an ipv4.
Ipv6 traffic was ok, but the phone disconnects because the lack of ipv4.
I assigned a static ipv4 and the connection came back.