After update no communication between VLAN

Hi,

So Turris get updated and now I cannot send packet through VLAN. Internet is working fine and I didn’t change my settings.

Please see below my VLAN configurations:

 config switch
         option name 'switch0'
         option reset '1'
         option enable_vlan '1'
 
 config switch_vlan
         option device 'switch0'
         option vlan '1'
         option ports '0 5t'
         option vid '1'
 
 config switch_vlan
         option device 'switch0'
         option vlan '2'
         option ports '1 5t'
         option vid '2'
 
 config switch_vlan
         option device 'switch0'
         option vlan '3'
         option ports '4 6'
         option vid '3'

Please let me know if you need further details.

as a minimum information you forgot to mention from which version are you updating to which version. Are you in RC channel upgrading to 3.10?

as a minimum information you forgot to mention from which version are you updating to which version. Are you in RC channel upgrading to 3.10?

Hmm…I can’t tell from which version the router upgraded but actually the version is 3.9.6.

(PS: What is RC channel ?)

RC=release candidate, which means it could be unstable, so only use it if you are not afraid of some more potential problems or if you want to help TO team with testing

RC=release candidate, which means it could be unstable, so only use it if you are not afraid of some more potential problems or if you want to help TO team with testing

Understood.

However, I didn’t plug the router since a while so when I did it, it just auto-updated.

Hi again,

it seems other stuff are broken. I can’t ping other hosts in the LAN by using hostname (even from the router). Hostname, settings are correct…And the DHCP doesn’t provide the search domain to any host.

So it seems since that auto-update (and without changing any settings) something has been broken. But I don’t know what. But most importantly I would like to fix the VLAN issue.

I got destination host unreachable when I ping other hosts in other VLANs.

# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'
        option masq '1'
        option mtu_fix '1'
        option family 'ipv4'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option input 'ACCEPT'
        option network 'wan'
        option forward 'ACCEPT'
        option family 'ipv4'
        option masq '1'
        option mtu_fix '1'

config zone
        option name 'server'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option network 'server'
        option forward 'ACCEPT'
        option family 'ipv4'

config zone
        option name 'dmz'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option network 'dmz'
        option family 'ipv4'
        option forward 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option log '1'

config zone
        option name 'wifi01'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option network 'wifi01'
        option family 'ipv4'
        option masq '1'
        option mtu_fix '1'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config forwarding
        option dest 'lan'
        option src 'server'

config forwarding
        option dest 'server'
        option src 'lan'

config forwarding
        option dest 'server'
        option src 'wifi01'

config forwarding
        option dest 'wifi01'
        option src 'server'

config forwarding
        option dest 'dmz'
        option src 'lan'

config forwarding
        option dest 'dmz'
        option src 'wan'

config forwarding
        option dest 'lan'
        option src 'wan'

config forwarding
        option dest 'wan'
        option src 'lan'

config forwarding
        option dest 'lan'
        option src 'dmz'

config forwarding
        option dest 'wan'
        option src 'dmz'


config include
        option path '/etc/firewall.user'

config include
        option path '/etc/firewall.d/with_reload/firewall.include.sh'
        option reload '1'

config include
       option path '/etc/firewall.d/without_reload/firewall.include.sh'
       option reload '0'

up ?

hmm…well I got this issue after TO auto-update. I didn’t change anything in the settings and everything worked well. So…I don’t really know what to do. My settings seems correct.