After reboot clock is ahead

The last few reboots i noticed the clock was 2 weeks ahead, i noticed because dns would not work with a date that far into the future, i don’t know since when it behaves like this, is anyone experiencing the same thing?

I recommend enabling NTP client to keep the clock accurate.

Log into Turris Omnia.

$ cd /etc/config
$ diff -u system system-opkg
# merge appropriate changes from system-opkg into system,
# most importantly the under "config timeserver ntp", you need the
# "list server     '217.31.202.100'" with IP addresses, which will work
# when the resolver does not work due to time skew.  Then, add 
# "option enabled 1" in that section, too.
#
# (it is a good idea to check for other *-opkg config files
#  and to review changes for merge)
# $ find /etc -name \*-opkg

@miska Turris Team probably should update /etc/init.d/ntpdate to use ntp.nic.cz IP addresses to attempt to set the time when Turris Omnia reboots, even if DNS resolution is not working.

1 Like