Access network shares on Omnia via OpenVPN

I’m trying to access a network share hosted directly on Omnia (Luci->Services->Network shares to a local disk connected to Omnia). I can access is from the LAN via Samba (using File Explorer in Windows). IP is

I then set up via ReForis an OpenVPN server and am using the OpenVPN Connect client on Windows. I can connect to the VPN with private IP

In Luci I also set Forwarding: accept for the vpn_turris → LAN/WAN zone. However I can’t connect to the network share via the VPN. I haven’t messed with any setting, everything else is at the default settings.

Any ideas?

“this device” zone is a thing IIRC.

Seems to be a client problem. Tried using OpenVPN Connect client on Android and an SMB browser and it worked fine. Not sure why it won’t connect from Windows file explorer. I tried setting the OpenVPN server setting “route all traffic via VPN” in case Windows was routing the request to via the default (non-VPN) gateway, but still no luck.

Now Window explorer asks me for a username/password (which suggested that it’s at least connected to the sambd server). However I have guest access enabled in the Network share setting, and it’s doesn’t ask me for a user/pass when I’m on the same LAN. I have no user setup for samba, just accessing via guest. I tried leaving blank and user “guest” but nothing works.

Pretty confusing since anonymous login works fine from my android SMB browser via OpenVPN.