5Ghz stopped working

I come to work today,
And 5Ghz wifi is off, there was no outage ( omnia is on huge ass UPS ), 2.4Ghz worked fine.

I turned the interface off and on in LuCi, that made it visible again, but unable to connect to. Reboot of router fixed it.

noticed some errors in log:

PasteBin

Aaaan now it happened again, 5Ghz disappeared,
There were some error messages like this:

PasteBin

But than nothing for a while, and 5Ghz just dropped…

DMESG:
PasteBin

It looks there were some update during night, as my router was restarted around 02:30 AM CET and i have similar messages in the log. Anyway nobody at home now and IP camera is connected to 2.40 GHz wifi, so dont know, if 5.0 GHz works or not now.

I had my auto update disabled, but turned it on now, kernel updated, did reboot and now I’m waiting …

Hi! If it happens again I have two suggestions:

  1. it might be a problem in OpenWRT kernel that has patched 80211 subsystem. We will read through the patches and try to find possible problems. But it will take some time. If you have time for experiments, you can try to build the image yourself without the patches. Or you can test it with the Debian image, which uses kernel that is much closer to vanilla, than OpenWRT.

  2. Another possibility is that the 5GHz card has disappeared from PCIe bus. Can you provide the whole dmesg?

After update today it is holding the 5Ghz steady so far. I did not save the old dmesg and after reboot it cleared… if it happens again I will copy the whole thing and post it here.

5 GHz works, so that strange messages in the log did not make wifi not working. I guess issue can be closed.

I would wait till tomorrow and confirm

I’m having a very similar issue. Since latest update my 5GHz wifi keeps disappearing/failing.

Any suggestions?

Could you guys post the system log. Also the output of these commands

lspci

you might have to install pciutils to be able to use lspci

ifconfig

iwconfig

cat /etc/config/wireless

Do hide your ssid + passwords.

So far so good on my side, but there was nothing connected to 5Ghz, now I’m connected to it and see if it holds whole day.

And it happened again, wifi dropped, but this time come back.

This is what was in dmesg:

http://pastebin.com/pR0AA4DY

I’m curious as what is this:

43.382084] ath10k_pci 0000:02:00.0: ATH10K_END
[ 45.695569] device veth574J3X entered promiscuous mode
[ 45.699183] IPv6: ADDRCONF(NETDEV_UP): veth574J3X: link is not ready
[ 45.699196] br-lan: port 5(veth574J3X) entered forwarding state
[ 45.699217] br-lan: port 5(veth574J3X) entered forwarding state
[ 45.706486] br-lan: port 5(veth574J3X) entered disabled state
[ 45.815465] eth0: renamed from veth90HELN
[ 45.851748] IPv6: ADDRCONF(NETDEV_CHANGE): veth574J3X: link becomes ready
[ 45.851821] br-lan: port 5(veth574J3X) entered forwarding state
[ 45.851850] br-lan: port 5(veth574J3X) entered forwarding state
[ 47.850703] br-lan: port 5(veth574J3X) entered forwarding state

What is that device ?

My whole messages log:

http://pastebin.com/ZyMeaAXA

Looks like something with IPv6, but I don’t use that addressing at all, how to completely disable IPv6 on Turris ?

Looks like router rebooted on its own
root@Bankrot_Router_Omnia:/tmp/log# uptime
09:43:53 up 10 min, load average: 0.00, 0.03, 0.00

what on earth ? :frowning: there is constant issue with this, every week at least once something I have to deal with

Also seems like it doesn’t keep at least one last log of messages, and rewrite the message log after boot, well this is fantastic for solving issues when you can’t find what happened :frowning: there should be messages.old by default

Veth interfaces of the LXC containers.

Thanks that actually helped as there is one container unused, so what I did after the reboot:

  • removed unused container
  • opkg update;
    opkg remove ath10k-firmware-qca988x-ct;
    opkg installath10k-firmware-qca988x;
    reboot

as suggested in other thread

  • added secondary location for syslog-ng so it also logs to permanent storage

And now I’m waiting…I’m afraid to say “so far so good” as when I do it breaks 5 min after :smiley:

Update after changes above:
root@Bankrot_Router_Omnia:~# uptime
07:25:16 up 21:19, load average: 0.00, 0.01, 0.00

“so far so good”

Hi guys, today I saw for the first time 5GHz signal to disappear. The router was restarted yesterday with the latest kernel.

So I saw here Vlados’s the advice about the firmware, I did opkg remove ath10k-firmware-qca988x-ct; opkg install ath10k-firmware-qca988x

but now I got an e-mail from updater, he is not happy:

Error notifications

Updater failed:
[string “transaction”]:310: [string “transaction”]:143: Collisions:
• /lib/firmware/ath10k/QCA988X/hw2.0/board.bin: ath10k-firmware-qca988x (existing), ath10k-firmware-qca988x-ct (new)

hmm strange, I did not get any email like that from router, and so far no reboot or wifi drop for one day:
Router_Omnia:~# uptime
11:23:19 up 1 day, 1:17, load average: 0.22, 0.19, 0.17

maybe you didn’t set-up updater mails?
you can also try manually, the same warning after:
opkg update
updater.sh

You are right, ( I have the updater setup for mails, maybe it just didn’t run from then ) but yes I have the same message:

root@Router_Omnia:~# updater.sh
WARN:Script revision-specific not found, but ignoring its absence as requested
WARN:Script serial-specific not found, but ignoring its absence as requested
INFO:Queue install of ath10k-firmware-qca988x-ct/turris/2016-09-13-b063774393b184c6e1626dec81cf5270cc213c69-1
INFO:Executing preupdate hooks…
INFO:Subprogram output: /etc/updater/hook_preupdate/05_schnapps.sh:
Snapshot number 10 created

INFO:End of subprogram output
DIE:
[string “transaction”]:310: [string “transaction”]:143: Collisions:
• /lib/firmware/ath10k/QCA988X/hw2.0/board.bin: ath10k-firmware-qca988x (existing), ath10k-firmware-qca988x-ct (new)
uci: Entry not found
uci: Entry not found